summary refs log tree commit diff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index 60d5166821fc..1c3fb148410c 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -129,9 +129,10 @@ let
       #$machine->waitForUnit('getty@tty2');
       $machine->waitForUnit("rogue");
       $machine->waitForUnit("nixos-manual");
-      $machine->waitForUnit("dhcpcd");
 
       ${optionalString testChannel ''
+        $machine->waitForUnit("dhcpcd");
+
         # Allow the machine to talk to the fake nixos.org.
         $machine->succeed(
             "rm /etc/hosts",