summary refs log tree commit diff
path: root/nixos/tests/dnscrypt-proxy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/dnscrypt-proxy.nix')
-rw-r--r--nixos/tests/dnscrypt-proxy.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/tests/dnscrypt-proxy.nix b/nixos/tests/dnscrypt-proxy.nix
index 845623368250..1fcf3903b13e 100644
--- a/nixos/tests/dnscrypt-proxy.nix
+++ b/nixos/tests/dnscrypt-proxy.nix
@@ -26,7 +26,8 @@ import ./make-test.nix ({ pkgs, ... }: {
     $client->waitForUnit("dnsmasq");
 
     # The daemon is socket activated; sending a single ping should activate it.
+    $client->fail("systemctl is-active dnscrypt-proxy");
     $client->execute("${pkgs.iputils}/bin/ping -c1 example.com");
-    $client->succeed("systemctl is-active dnscrypt-proxy");
+    $client->waitUntilSucceeds("systemctl is-active dnscrypt-proxy");
   '';
 })