about summary refs log tree commit diff
path: root/nixos/tests/budgie.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/budgie.nix')
-rw-r--r--nixos/tests/budgie.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/tests/budgie.nix b/nixos/tests/budgie.nix
index 64a4e65fa7f6..5228e869b056 100644
--- a/nixos/tests/budgie.nix
+++ b/nixos/tests/budgie.nix
@@ -82,9 +82,9 @@ import ./make-test-python.nix ({ pkgs, lib, ... }: {
           machine.wait_until_succeeds("${su "budgie-screensaver-command -q"} | grep 'The screensaver is inactive'")
           machine.sleep(2)
 
-      with subtest("Open MATE terminal"):
-          machine.succeed("${su "mate-terminal >&2 &"}")
-          machine.wait_for_window("Terminal")
+      with subtest("Open GNOME terminal"):
+          machine.succeed("${su "gnome-terminal"}")
+          machine.wait_for_window("${user.name}@machine: ~")
 
       with subtest("Check if Budgie has ever coredumped"):
           machine.fail("coredumpctl --json=short | grep budgie")