about summary refs log tree commit diff
path: root/nixos/tests/avahi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/avahi.nix')
-rw-r--r--nixos/tests/avahi.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/tests/avahi.nix b/nixos/tests/avahi.nix
index 4091e7ece501..b6f18087c56f 100644
--- a/nixos/tests/avahi.nix
+++ b/nixos/tests/avahi.nix
@@ -21,12 +21,13 @@ import ./make-test.nix {
 
        # mDNS.
        $one->waitForUnit("network.target");
+       $two->waitForUnit("network.target");
+
        $one->succeed("avahi-resolve-host-name one.local | tee out >&2");
        $one->succeed("test \"`cut -f1 < out`\" = one.local");
        $one->succeed("avahi-resolve-host-name two.local | tee out >&2");
        $one->succeed("test \"`cut -f1 < out`\" = two.local");
 
-       $two->waitForUnit("network.target");
        $two->succeed("avahi-resolve-host-name one.local | tee out >&2");
        $two->succeed("test \"`cut -f1 < out`\" = one.local");
        $two->succeed("avahi-resolve-host-name two.local | tee out >&2");