about summary refs log tree commit diff
path: root/nixos/tests/agda.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/agda.nix')
-rw-r--r--nixos/tests/agda.nix43
1 files changed, 0 insertions, 43 deletions
diff --git a/nixos/tests/agda.nix b/nixos/tests/agda.nix
deleted file mode 100644
index a8e90725c06b..000000000000
--- a/nixos/tests/agda.nix
+++ /dev/null
@@ -1,43 +0,0 @@
-import ./make-test-python.nix ({ pkgs, ... }:
-
-let
-  hello-world = pkgs.writeText "hello-world" ''
-    {-# OPTIONS --guardedness #-}
-    open import IO
-    open import Level
-
-    main = run {0ℓ} (putStrLn "Hello World!")
-  '';
-in
-{
-  name = "agda";
-  meta = with pkgs.lib.maintainers; {
-    maintainers = [ alexarice turion ];
-  };
-
-  nodes.machine = { pkgs, ... }: {
-    environment.systemPackages = [
-      (pkgs.agda.withPackages {
-        pkgs = p: [ p.standard-library ];
-      })
-    ];
-    virtualisation.memorySize = 2000; # Agda uses a lot of memory
-  };
-
-  testScript = ''
-    # Minimal script that typechecks
-    machine.succeed("touch TestEmpty.agda")
-    machine.succeed("agda TestEmpty.agda")
-
-    # Hello world
-    machine.succeed(
-        "cp ${hello-world} HelloWorld.agda"
-    )
-    machine.succeed("agda -l standard-library -i . -c HelloWorld.agda")
-    # Check execution
-    assert "Hello World!" in machine.succeed(
-        "./HelloWorld"
-    ), "HelloWorld does not run properly"
-  '';
-}
-)