summary refs log tree commit diff
path: root/nixos/modules/virtualisation/openvswitch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/virtualisation/openvswitch.nix')
-rw-r--r--nixos/modules/virtualisation/openvswitch.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/nixos/modules/virtualisation/openvswitch.nix b/nixos/modules/virtualisation/openvswitch.nix
index b5155246fdad..1c77945a6cb5 100644
--- a/nixos/modules/virtualisation/openvswitch.nix
+++ b/nixos/modules/virtualisation/openvswitch.nix
@@ -92,13 +92,11 @@ in {
             --bootstrap-ca-cert=db:Open_vSwitch,SSL,ca_cert \
             --unixctl=ovsdb.ctl.sock \
             --pidfile=/var/run/openvswitch/ovsdb.pid \
-            --detach \
             /var/db/openvswitch/conf.db
           '';
         Restart = "always";
         RestartSec = 3;
         PIDFile = "/var/run/openvswitch/ovsdb.pid";
-        Type = "forking";
       };
       postStart = ''
         ${cfg.package}/bin/ovs-vsctl --timeout 3 --retry --no-wait init
@@ -114,11 +112,9 @@ in {
       serviceConfig = {
         ExecStart = ''
           ${cfg.package}/bin/ovs-vswitchd \
-          --pidfile=/var/run/openvswitch/ovs-vswitchd.pid \
-          --detach
+          --pidfile=/var/run/openvswitch/ovs-vswitchd.pid
         '';
         PIDFile = "/var/run/openvswitch/ovs-vswitchd.pid";
-        Type = "forking";
       };
     };
 
@@ -143,11 +139,10 @@ in {
           ${cfg.package}/bin/ovs-monitor-ipsec \
             --root-prefix ${runDir}/ipsec \
             --pidfile /var/run/openvswitch/ovs-monitor-ipsec.pid \
-            --monitor --detach \
+            --monitor \
             unix:/var/run/openvswitch/db.sock
         '';
         PIDFile = "/var/run/openvswitch/ovs-monitor-ipsec.pid";
-        Type = "forking";
       };
 
       preStart = ''