summary refs log tree commit diff
path: root/nixos/modules/virtualisation/nova-image.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/virtualisation/nova-image.nix')
-rw-r--r--nixos/modules/virtualisation/nova-image.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/virtualisation/nova-image.nix b/nixos/modules/virtualisation/nova-image.nix
index ab625dba11d3..5c9481b71278 100644
--- a/nixos/modules/virtualisation/nova-image.nix
+++ b/nixos/modules/virtualisation/nova-image.nix
@@ -46,10 +46,10 @@ with pkgs.lib;
 
           # Register the paths in the Nix database.
           printRegistration=1 perl ${pkgs.pathsFromGraph} /tmp/xchg/closure | \
-              chroot /mnt ${config.environment.nix}/bin/nix-store --load-db
+              chroot /mnt ${config.nix.package}/bin/nix-store --load-db
 
           # Create the system profile to allow nixos-rebuild to work.
-          chroot /mnt ${config.environment.nix}/bin/nix-env \
+          chroot /mnt ${config.nix.package}/bin/nix-env \
               -p /nix/var/nix/profiles/system --set ${config.system.build.toplevel}
 
           # `nixos-rebuild' requires an /etc/NIXOS.