summary refs log tree commit diff
path: root/nixos/modules/tasks/filesystems/btrfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/tasks/filesystems/btrfs.nix')
-rw-r--r--nixos/modules/tasks/filesystems/btrfs.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/nixos/modules/tasks/filesystems/btrfs.nix b/nixos/modules/tasks/filesystems/btrfs.nix
index 049f7708d739..8cfa1b6921d3 100644
--- a/nixos/modules/tasks/filesystems/btrfs.nix
+++ b/nixos/modules/tasks/filesystems/btrfs.nix
@@ -11,13 +11,13 @@ in
 {
   config = mkIf (any (fs: fs == "btrfs") config.boot.supportedFilesystems) {
 
-    system.fsPackages = [ pkgs.btrfsProgs ];
+    system.fsPackages = [ pkgs.btrfs-progs ];
 
     boot.initrd.kernelModules = mkIf inInitrd [ "btrfs" "crc32c" ];
 
     boot.initrd.extraUtilsCommands = mkIf inInitrd
       ''
-        copy_bin_and_libs ${pkgs.btrfsProgs}/bin/btrfs
+        copy_bin_and_libs ${pkgs.btrfs-progs}/bin/btrfs
         ln -sv btrfs $out/bin/btrfsck
         ln -sv btrfsck $out/bin/fsck.btrfs
       '';
@@ -31,13 +31,5 @@ in
       ''
         btrfs device scan
       '';
-
-    # !!! This is broken.  There should be a udev rule to do this when
-    # new devices are discovered.
-    jobs.udev.postStart =
-      ''
-        ${pkgs.btrfsProgs}/bin/btrfs device scan
-      '';
-
   };
 }