summary refs log tree commit diff
path: root/nixos/modules/system/boot/loader/raspberrypi/raspberrypi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/system/boot/loader/raspberrypi/raspberrypi.nix')
-rw-r--r--nixos/modules/system/boot/loader/raspberrypi/raspberrypi.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/loader/raspberrypi/raspberrypi.nix b/nixos/modules/system/boot/loader/raspberrypi/raspberrypi.nix
index adf13ce6098c..f974d07da9e5 100644
--- a/nixos/modules/system/boot/loader/raspberrypi/raspberrypi.nix
+++ b/nixos/modules/system/boot/loader/raspberrypi/raspberrypi.nix
@@ -45,7 +45,7 @@ let
       arm_control=0x200
     '' + optional cfg.uboot.enable ''
       kernel=u-boot-rpi.bin
-    '');
+    '' + optional (cfg.firmwareConfig != null) cfg.firmwareConfig);
 
 in
 
@@ -89,6 +89,15 @@ in
         };
 
       };
+
+      firmwareConfig = mkOption {
+        default = null;
+        type = types.nullOr types.string;
+        description = ''
+          Extra options that will be appended to <literal>/boot/config.txt</literal> file.
+          For possible values, see: https://www.raspberrypi.org/documentation/configuration/config-txt/
+        '';
+      };
     };
   };