summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index 0a3368ae4167..4cea6279e507 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -117,6 +117,7 @@ in
     };
 
     system.modulesTree = mkOption {
+      type = types.listOf types.path;
       internal = true;
       default = [];
       description = ''
@@ -124,7 +125,6 @@ in
         built outside of the kernel.  Combine these into a single tree of
         symlinks because modprobe only supports one directory.
       '';
-      merge = mergeListOption;
       # Convert the list of path to only one path.
       apply = pkgs.aggregateModules;
     };