summary refs log tree commit diff
path: root/nixos/modules/system/boot/kernel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/system/boot/kernel.nix')
-rw-r--r--nixos/modules/system/boot/kernel.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/kernel.nix b/nixos/modules/system/boot/kernel.nix
index 5eba2165435a..d78f9d9389c6 100644
--- a/nixos/modules/system/boot/kernel.nix
+++ b/nixos/modules/system/boot/kernel.nix
@@ -24,9 +24,13 @@ in
     boot.kernel.features = mkOption {
       default = {};
       example = literalExample "{ debug = true; }";
+      internal = true;
       description = ''
         This option allows to enable or disable certain kernel features.
-        grep features pkgs/os-specific/linux/kernel/common-config.nix
+        It's not API, because it's about kernel feature sets, that
+        make sense for specific use cases. Mostly along with programs,
+        which would have separate nixos options.
+        `grep features pkgs/os-specific/linux/kernel/common-config.nix`
       '';
     };