summary refs log tree commit diff
path: root/nixos/modules/services/x11/window-managers/i3.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/window-managers/i3.nix')
-rw-r--r--nixos/modules/services/x11/window-managers/i3.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/services/x11/window-managers/i3.nix b/nixos/modules/services/x11/window-managers/i3.nix
index 6777a95ddc8c..e53d86187ae6 100644
--- a/nixos/modules/services/x11/window-managers/i3.nix
+++ b/nixos/modules/services/x11/window-managers/i3.nix
@@ -30,14 +30,14 @@ in
     services.xserver.windowManager = {
       session = [{
         name = "i3";
-        start = "
+        start = ''
           ${pkgs.i3}/bin/i3 ${optionalString (cfg.configFile != null)
             "-c \"${cfg.configFile}\""
           } &
           waitPID=$!
-        ";
+        '';
       }];
     };
-    environment.x11Packages = [ pkgs.i3 ];
+    environment.systemPackages = [ pkgs.i3 ];
   };
 }