about summary refs log tree commit diff
path: root/nixos/modules/services/x11/display-managers/sddm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/x11/display-managers/sddm.nix')
-rw-r--r--nixos/modules/services/x11/display-managers/sddm.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/nixos/modules/services/x11/display-managers/sddm.nix b/nixos/modules/services/x11/display-managers/sddm.nix
index 7a17a222bcab..16d1e89e8d96 100644
--- a/nixos/modules/services/x11/display-managers/sddm.nix
+++ b/nixos/modules/services/x11/display-managers/sddm.nix
@@ -27,6 +27,7 @@ let
     ${cfg.stopScript}
   '';
 
+
   cfgFile = pkgs.writeText "sddm.conf" ''
     [General]
     HaltCommand=${pkgs.systemd}/bin/systemctl poweroff
@@ -154,7 +155,7 @@ in
               type = types.bool;
               default = false;
               description = ''
-                Automatically log in as the sepecified <option>autoLogin.user</option>.
+                Automatically log in as <option>autoLogin.user</option>.
               '';
             };
 
@@ -162,7 +163,7 @@ in
               type = types.nullOr types.str;
               default = null;
               description = ''
-                User to be used for the autologin.
+                User to be used for the automatic login.
               '';
             };
 
@@ -170,8 +171,8 @@ in
               type = types.bool;
               default = false;
               description = ''
-                If true automatic login will kick in again on session exit, otherwise it
-                will work only the first time.
+                If true automatic login will kick in again on session exit (logout), otherwise it
+                will only log in automatically when the display-manager is started.
               '';
             };
           };