summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/zope2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/web-servers/zope2.nix')
-rw-r--r--nixos/modules/services/web-servers/zope2.nix39
1 files changed, 20 insertions, 19 deletions
diff --git a/nixos/modules/services/web-servers/zope2.nix b/nixos/modules/services/web-servers/zope2.nix
index bbe4d10f83d0..ef3cffd582ee 100644
--- a/nixos/modules/services/web-servers/zope2.nix
+++ b/nixos/modules/services/web-servers/zope2.nix
@@ -75,25 +75,26 @@ in
     services.zope2.instances = mkOption {
       default = {};
       type = types.loaOf types.optionSet;
-      example = {
-        plone01 = {
-          http_address = "127.0.0.1:8080";
-          extra =
-            ''
-            <zodb_db main>
-              mount-point /
-              cache-size 30000
-              <blobstorage>
-                  blob-dir /var/lib/zope2/plone01/blobstorage
-                  <filestorage>
-                  path /var/lib/zope2/plone01/filestorage/Data.fs
-                  </filestorage>
-              </blobstorage>
-            </zodb_db>
-            '';
-
-        };
-      };
+      example = literalExample ''
+        {
+          plone01 = {
+            http_address = "127.0.0.1:8080";
+            extra =
+              '''
+              <zodb_db main>
+                mount-point /
+                cache-size 30000
+                <blobstorage>
+                    blob-dir /var/lib/zope2/plone01/blobstorage
+                    <filestorage>
+                    path /var/lib/zope2/plone01/filestorage/Data.fs
+                    </filestorage>
+                </blobstorage>
+              </zodb_db>
+              ''';
+          };
+        }
+      '';
       description = "zope2 instances to be created automaticaly by the system.";
       options = [ zope2Opts ];
     };