summary refs log tree commit diff
path: root/nixos/modules/services/web-servers/nginx/location-options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/web-servers/nginx/location-options.nix')
-rw-r--r--nixos/modules/services/web-servers/nginx/location-options.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nixos/modules/services/web-servers/nginx/location-options.nix b/nixos/modules/services/web-servers/nginx/location-options.nix
index 6537e45a459d..ce3462bed0a4 100644
--- a/nixos/modules/services/web-servers/nginx/location-options.nix
+++ b/nixos/modules/services/web-servers/nginx/location-options.nix
@@ -27,6 +27,14 @@ with lib;
         Root directory for requests.
       '';
     };
+
+    extraConfig = mkOption {
+      type = types.lines;
+      default = "";
+      description = ''
+        These lines go to the end of the location verbatim.
+      '';
+    };
   };
 }