summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/atlassian/crowd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/web-apps/atlassian/crowd.nix')
-rw-r--r--nixos/modules/services/web-apps/atlassian/crowd.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/services/web-apps/atlassian/crowd.nix b/nixos/modules/services/web-apps/atlassian/crowd.nix
index 2a5f08046382..a44aaf0238b9 100644
--- a/nixos/modules/services/web-apps/atlassian/crowd.nix
+++ b/nixos/modules/services/web-apps/atlassian/crowd.nix
@@ -9,9 +9,10 @@ let
   pkg = pkgs.atlassian-crowd.override {
     home = cfg.home;
     port = cfg.listenPort;
-    proxyUrl = "${cfg.proxy.scheme}://${cfg.proxy.name}:${toString cfg.proxy.port}";
     openidPassword = cfg.openidPassword;
-  };
+  } // (optionalAttrs cfg.proxy.enable {
+    proxyUrl = "${cfg.proxy.scheme}://${cfg.proxy.name}:${toString cfg.proxy.port}";
+  });
 
 in
 
@@ -142,13 +143,12 @@ in
           ${pkg}/apache-tomcat/conf/server.xml.dist > ${cfg.home}/server.xml
       '';
 
-      script = "${pkg}/start_crowd.sh -fg";
-
       serviceConfig = {
         User = cfg.user;
         Group = cfg.group;
         PrivateTmp = true;
         PermissionsStartOnly = true;
+        ExecStart = "${pkg}/start_crowd.sh -fg";
       };
     };
   };