about summary refs log tree commit diff
path: root/nixos/modules/services/security/frandom.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/security/frandom.nix')
-rw-r--r--nixos/modules/services/security/frandom.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/nixos/modules/services/security/frandom.nix b/nixos/modules/services/security/frandom.nix
deleted file mode 100644
index 2d43d12e541d..000000000000
--- a/nixos/modules/services/security/frandom.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{lib, config, ...}:
-
-let kernel = config.boot.kernelPackages;
-in
-
-{
-
-  ###### interface
-
-  options = {
-
-    services.frandom.enable = lib.mkOption {
-      default = false;
-      type = lib.types.bool;
-      description = ''
-        enable the /dev/frandom device (a very fast random number generator)
-      '';
-    };
-
-  };
-
-
-  ###### implementation
-
-  config = lib.mkIf config.services.frandom.enable {
-    boot.kernelModules = [ "frandom" ];
-    boot.extraModulePackages = [ kernel.frandom ];
-    services.udev.packages = [ kernel.frandom ];
-  };
-
-}