about summary refs log tree commit diff
path: root/nixos/modules/services/networking/shairport-sync.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/shairport-sync.nix')
-rw-r--r--nixos/modules/services/networking/shairport-sync.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/services/networking/shairport-sync.nix b/nixos/modules/services/networking/shairport-sync.nix
index 0b87140b0d8d..36ecb74ffc95 100644
--- a/nixos/modules/services/networking/shairport-sync.nix
+++ b/nixos/modules/services/networking/shairport-sync.nix
@@ -27,7 +27,7 @@ in
       };
 
       arguments = mkOption {
-        default = "-v -o pulse";
+        default = "-v -d pulse";
         description = ''
           Arguments to pass to the daemon. Defaults to a local pulseaudio
           server.
@@ -72,6 +72,7 @@ in
         serviceConfig = {
           User = cfg.user;
           ExecStart = "${pkgs.shairport-sync}/bin/shairport-sync ${cfg.arguments}";
+          RuntimeDirectory = "shairport-sync";
         };
       };