about summary refs log tree commit diff
path: root/nixos/modules/services/networking/shadowsocks.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/shadowsocks.nix')
-rw-r--r--nixos/modules/services/networking/shadowsocks.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/services/networking/shadowsocks.nix b/nixos/modules/services/networking/shadowsocks.nix
index fe6d65a5f963..af12db590f00 100644
--- a/nixos/modules/services/networking/shadowsocks.nix
+++ b/nixos/modules/services/networking/shadowsocks.nix
@@ -35,10 +35,10 @@ in
       };
 
       localAddress = mkOption {
-        type = types.str;
-        default = "0.0.0.0";
+        type = types.coercedTo types.str singleton (types.listOf types.str);
+        default = [ "[::0]" "0.0.0.0" ];
         description = ''
-          Local address to which the server binds.
+          Local addresses to which the server binds.
         '';
       };