summary refs log tree commit diff
path: root/nixos/modules/services/networking/ndppd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/ndppd.nix')
-rw-r--r--nixos/modules/services/networking/ndppd.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/nixos/modules/services/networking/ndppd.nix b/nixos/modules/services/networking/ndppd.nix
new file mode 100644
index 000000000000..1d6c48dd8d37
--- /dev/null
+++ b/nixos/modules/services/networking/ndppd.nix
@@ -0,0 +1,47 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+  cfg = config.services.ndppd;
+
+  configFile = pkgs.runCommand "ndppd.conf" {} ''
+    substitute ${pkgs.ndppd}/etc/ndppd.conf $out \
+      --replace eth0 ${cfg.interface} \
+      --replace 1111:: ${cfg.network}
+  '';
+in {
+  options = {
+    services.ndppd = {
+      enable = mkEnableOption "daemon that proxies NDP (Neighbor Discovery Protocol) messages between interfaces";
+      interface = mkOption {
+        type = types.string;
+        default = "eth0";
+        example = "ens3";
+        description = "Interface which is on link-level with router.";
+      };
+      network = mkOption {
+        type = types.string;
+        default = "1111::";
+        example = "2001:DB8::/32";
+        description = "Network that we proxy.";
+      };
+      configFile = mkOption {
+        type = types.nullOr types.path;
+        default = null;
+        description = "Path to configuration file.";
+      };
+    };
+  };
+
+  config = mkIf cfg.enable {
+    systemd.packages = [ pkgs.ndppd ];
+    environment.etc."ndppd.conf".source = if (cfg.configFile != null) then cfg.configFile else configFile;
+    systemd.services.ndppd = {
+      serviceConfig.RuntimeDirectory = [ "ndppd" ];
+      wantedBy = [ "multi-user.target" ];
+    };
+  };
+
+  meta.maintainers = with maintainers; [ gnidorah ];
+}