summary refs log tree commit diff
path: root/nixos/modules/services/networking/btsync.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/networking/btsync.nix')
-rw-r--r--nixos/modules/services/networking/btsync.nix25
1 files changed, 12 insertions, 13 deletions
diff --git a/nixos/modules/services/networking/btsync.nix b/nixos/modules/services/networking/btsync.nix
index fe462aeba9cb..572a7387316b 100644
--- a/nixos/modules/services/networking/btsync.nix
+++ b/nixos/modules/services/networking/btsync.nix
@@ -83,15 +83,13 @@ in
         type = types.bool;
         default = false;
         description = ''
-          If enabled, start the Bittorrent Sync daemon. Once enabled,
-          you can interact with the service through the Web UI, or
-          configure it in your NixOS configuration. Enabling the
-          <literal>btsync</literal> service also installs a
-          multi-instance systemd unit which can be used to start
-          user-specific copies of the daemon. Once installed, you can
-          use <literal>systemctl start btsync@user</literal> to start
-          the daemon only for user <literal>user</literal>, using the
-          configuration file located at
+          If enabled, start the Bittorrent Sync daemon. Once enabled, you can
+          interact with the service through the Web UI, or configure it in your
+          NixOS configuration. Enabling the <literal>btsync</literal> service
+          also installs a systemd user unit which can be used to start
+          user-specific copies of the daemon. Once installed, you can use
+          <literal>systemctl --user start btsync</literal> as your user to start
+          the daemon using the configuration file located at
           <literal>$HOME/.config/btsync.conf</literal>.
         '';
       };
@@ -212,7 +210,9 @@ in
         default = "/var/lib/btsync/";
         example = "/var/lib/btsync/";
         description = ''
-          Where to store the bittorrent sync files.
+          Where BitTorrent Sync will store it's database files (containing
+          things like username info and licenses). Generally, you should not
+          need to ever change this.
         '';
       };
 
@@ -311,12 +311,11 @@ in
       };
     };
 
-    systemd.services."btsync@" = with pkgs; {
-      description = "Bittorrent Sync Service for %i";
+    systemd.user.services.btsync = with pkgs; {
+      description = "Bittorrent Sync user service";
       after       = [ "network.target" "local-fs.target" ];
       serviceConfig = {
         Restart   = "on-abort";
-        User      = "%i";
         ExecStart =
           "${bittorrentSync}/bin/btsync --nodaemon --config %h/.config/btsync.conf";
       };