summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/sensu/sites.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/sensu/sites.nix')
-rw-r--r--nixos/modules/services/monitoring/sensu/sites.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/sensu/sites.nix b/nixos/modules/services/monitoring/sensu/sites.nix
new file mode 100644
index 000000000000..f983305d825c
--- /dev/null
+++ b/nixos/modules/services/monitoring/sensu/sites.nix
@@ -0,0 +1,59 @@
+{ lib }:
+
+{
+  options = with lib; {
+    name = mkOption {
+      type = types.str;
+      default = "Site 1";
+      description = "Name of the site.";
+    };
+
+    host = mkOption {
+      type = types.str;
+      default = "localhost";
+      description = "Host name";
+    };
+
+    port = mkOption {
+      type = types.int;
+      default = 4567;
+      description = "Port";
+    };
+
+    ssl = mkOption {
+      type = types.bool;
+      default = true;
+      description = "Enable SSL";
+    };
+
+    insecure = mkOption {
+      type = types.bool;
+      default = true;
+      description = "Insecure";
+    };
+
+    user = mkOption {
+      type = types.str;
+      default = "";
+      description = "User name for authentication";
+    };
+
+    pass = mkOption {
+      type = types.str;
+      default = "";
+      description = "Password for authentication";
+    };
+
+    path = mkOption {
+      type = types.str;
+      default = "";
+      description = "Path?";
+    };
+
+    timeout = mkOption {
+      type = types.int;
+      default = 5;
+      description = "Timeout";
+    };
+  };
+}