summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/sensu/plugins.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/sensu/plugins.nix')
-rw-r--r--nixos/modules/services/monitoring/sensu/plugins.nix83
1 files changed, 83 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/sensu/plugins.nix b/nixos/modules/services/monitoring/sensu/plugins.nix
new file mode 100644
index 000000000000..95d70f88391b
--- /dev/null
+++ b/nixos/modules/services/monitoring/sensu/plugins.nix
@@ -0,0 +1,83 @@
+{ lib }:
+
+{
+  options = with lib; with types; {
+
+    mailer = mkOption {
+      description = "sensu-plugins-mailer";
+      default = {};
+      type = submodule {
+        options = {
+          mail_from = mkOption {
+            type = str;
+            description = "Sender";
+          };
+
+          mail_to = mkOption {
+            type = str;
+            description = "Recipient";
+          };
+        };
+      };
+    };
+  };
+}
+
+
+
+
+
+#     type = mkOption {
+#       type = enum [ "pipe" "tcp" "udp" "transport" "set" ];
+#       description = "Type of handler.";
+#     };
+
+#     filters = mkOption {
+#       type = listOf str;
+#       default = [];
+#       description = "List of filters.";
+#     };
+
+#     severities = mkOption {
+#       type = listOf (enum [ "warning" "critical" "unknown" ]);
+#       default = [ "unknown" ];
+#       description = "Severities to handle.";
+#     };
+
+#     subscribers = mkOption {
+#       type = listOf str;
+#       default = [];
+#       description = "Subscribers";
+#     };
+
+#     timeout = mkOption {
+#       type = int;
+#       default = 30;
+#       description = "Timeout.";
+#     };
+
+#     command = mkOption {
+#       type = str;
+#       default = "";
+#       description = "Command for type pipe.";
+#     };
+
+#     socket = mkOption {
+#       type = attrs;
+#       default = {};
+#       description = "Socket for type tcp or udp.";
+#     };
+
+#     pipe = mkOption {
+#       type = attrs;
+#       default = {};
+#       description = "Pipe for type pipe.";
+#     };
+
+#     handlers = mkOption {
+#       type = listOf str;
+#       default = [];
+#       description = "Handlers for type set.";
+#     };
+#   };
+# }