summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/sensu/host_port_pair.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/sensu/host_port_pair.nix')
-rw-r--r--nixos/modules/services/monitoring/sensu/host_port_pair.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/sensu/host_port_pair.nix b/nixos/modules/services/monitoring/sensu/host_port_pair.nix
new file mode 100644
index 000000000000..283a8f59acfd
--- /dev/null
+++ b/nixos/modules/services/monitoring/sensu/host_port_pair.nix
@@ -0,0 +1,17 @@
+{ lib, name, defaultHost ? null, defaultPort ? null, options ? {} }:
+
+{
+  options = with lib; with types; {
+    host = mkOption {
+      type = str;
+      default = defaultHost;
+      description = "The hostname of ${name}";
+    };
+
+    port = mkOption {
+      type = int;
+      default = defaultPort;
+      description = "The port of ${name}";
+    };
+  } // options;
+}