summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/sensu/client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/sensu/client.nix')
-rw-r--r--nixos/modules/services/monitoring/sensu/client.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/sensu/client.nix b/nixos/modules/services/monitoring/sensu/client.nix
new file mode 100644
index 000000000000..dc4c9864c09a
--- /dev/null
+++ b/nixos/modules/services/monitoring/sensu/client.nix
@@ -0,0 +1,49 @@
+{ lib }:
+
+{
+  options = with lib; with types; {
+    name = mkOption {
+      type = str;
+      default = "";
+      description = "Name of the client.";
+    };
+
+    address = mkOption {
+      type = str;
+      default = "";
+      description = "IP address";
+    };
+
+    subscriptions = mkOption {
+      type = listOf str;
+      default = [ ];
+      description = "Subscriptions";
+    };
+
+    socket = mkOption {
+      description = "The socket configuration.";
+      default = {};
+      type = submodule {
+        options = {
+          bind = mkOption {
+            type = str;
+            default = "127.0.0.1";
+            description = "The IP address on which the client listens.";
+          };
+
+          port = mkOption {
+            type = int;
+            default = 3030;
+            description = "The port on which the client listens.";
+          };
+        };
+      };
+    };
+
+    vars = mkOption {
+      type = attrs;
+      default = {};
+      description = "Custom attributes/variables.";
+    };
+  };
+}