summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/fusion-inventory.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/fusion-inventory.nix')
-rw-r--r--nixos/modules/services/monitoring/fusion-inventory.nix9
1 files changed, 2 insertions, 7 deletions
diff --git a/nixos/modules/services/monitoring/fusion-inventory.nix b/nixos/modules/services/monitoring/fusion-inventory.nix
index fdd27938ea7b..1c00f3c299e9 100644
--- a/nixos/modules/services/monitoring/fusion-inventory.nix
+++ b/nixos/modules/services/monitoring/fusion-inventory.nix
@@ -22,15 +22,10 @@ in {
 
     services.fusionInventory = {
 
-      enable = mkOption {
-        default = false;
-        description = ''
-          Whether to run the Fusion Inventory agent on this machine.
-        '';
-      };
+      enable = mkEnableOption "Fusion Inventory Agent";
 
       servers = mkOption {
-        type = types.listOf types.string;
+        type = types.listOf types.str;
         description = ''
           The urls of the OCS/GLPI servers to connect to.
         '';