summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/bosun.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/monitoring/bosun.nix')
-rw-r--r--nixos/modules/services/monitoring/bosun.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/nixos/modules/services/monitoring/bosun.nix b/nixos/modules/services/monitoring/bosun.nix
index 7a53ce174542..7e8dea4ec024 100644
--- a/nixos/modules/services/monitoring/bosun.nix
+++ b/nixos/modules/services/monitoring/bosun.nix
@@ -30,6 +30,7 @@ in {
 
       package = mkOption {
         type = types.package;
+        default = pkgs.bosun;
         example = literalExample "pkgs.bosun";
         description = ''
           bosun binary to use.
@@ -95,8 +96,6 @@ in {
 
   config = mkIf cfg.enable {
   
-    services.bosun.package = mkDefault pkgs.bosun; 
-
     systemd.services.bosun = {
       description = "bosun metrics collector (part of Bosun)";
       wantedBy = [ "multi-user.target" ];