summary refs log tree commit diff
path: root/nixos/modules/services/misc/rippled.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/misc/rippled.nix')
-rw-r--r--nixos/modules/services/misc/rippled.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/nixos/modules/services/misc/rippled.nix b/nixos/modules/services/misc/rippled.nix
index d940c1bc900e..c6b67e8498ca 100644
--- a/nixos/modules/services/misc/rippled.nix
+++ b/nixos/modules/services/misc/rippled.nix
@@ -208,6 +208,7 @@ in
 	description = "Which rippled package to use.";
 	type = types.package;
 	default = pkgs.rippled;
+	defaultText = "pkgs.rippled";
       };
 
       ports = mkOption {
@@ -238,7 +239,7 @@ in
       nodeDb = mkOption {
 	description = "Rippled main database options.";
 	type = types.nullOr types.optionSet;
-	options = [dbOptions];
+	options = dbOptions;
 	default = {
 	  type = "rocksdb";
 	  extraOpts = ''
@@ -254,14 +255,14 @@ in
       tempDb = mkOption {
 	description = "Rippled temporary database options.";
 	type = types.nullOr types.optionSet;
-	options = [dbOptions];
+	options = dbOptions;
 	default = null;
       };
 
       importDb = mkOption {
 	description = "Settings for performing a one-time import.";
 	type = types.nullOr types.optionSet;
-	options = [dbOptions];
+	options = dbOptions;
 	default = null;
       };