summary refs log tree commit diff
path: root/nixos/modules/services/misc/mesos-master.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/misc/mesos-master.nix')
-rw-r--r--nixos/modules/services/misc/mesos-master.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/services/misc/mesos-master.nix b/nixos/modules/services/misc/mesos-master.nix
index 11e21c334472..52f08c53b1dc 100644
--- a/nixos/modules/services/misc/mesos-master.nix
+++ b/nixos/modules/services/misc/mesos-master.nix
@@ -85,8 +85,9 @@ in {
         ExecStart = ''
           ${pkgs.mesos}/bin/mesos-master \
             --port=${toString cfg.port} \
-            --zk=${cfg.zk} \
-            ${if cfg.quorum == 0 then "--registry=in_memory" else "--registry=replicated_log --quorum=${toString cfg.quorum}"} \
+            ${if cfg.quorum == 0
+              then "--registry=in_memory"
+              else "--zk=${cfg.zk} --registry=replicated_log --quorum=${toString cfg.quorum}"} \
             --work_dir=${cfg.workDir} \
             --logging_level=${cfg.logLevel} \
             ${toString cfg.extraCmdLineOptions}