summary refs log tree commit diff
path: root/nixos/modules/services/misc/mesos-master.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/misc/mesos-master.nix')
-rw-r--r--nixos/modules/services/misc/mesos-master.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/misc/mesos-master.nix b/nixos/modules/services/misc/mesos-master.nix
index 52f08c53b1dc..497646b2b418 100644
--- a/nixos/modules/services/misc/mesos-master.nix
+++ b/nixos/modules/services/misc/mesos-master.nix
@@ -13,7 +13,7 @@ in {
       enable = mkOption {
         description = "Whether to enable the Mesos Master.";
         default = false;
-        type = types.uniq types.bool;
+        type = types.bool;
       };
 
       port = mkOption {
@@ -45,7 +45,7 @@ in {
           See https://mesos.apache.org/documentation/latest/configuration/
         '';
         default = [ "" ];
-        type = types.listOf types.string;
+        type = types.listOf types.str;
         example = [ "--credentials=VALUE" ];
       };