summary refs log tree commit diff
path: root/nixos/modules/services/misc/ihaskell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/misc/ihaskell.nix')
-rw-r--r--nixos/modules/services/misc/ihaskell.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/nixos/modules/services/misc/ihaskell.nix b/nixos/modules/services/misc/ihaskell.nix
index c177d68c8fe0..d0e9b839e754 100644
--- a/nixos/modules/services/misc/ihaskell.nix
+++ b/nixos/modules/services/misc/ihaskell.nix
@@ -15,14 +15,12 @@ in
   options = {
     services.ihaskell = {
       enable = mkOption {
-        type = lib.types.bool;
         default = false;
         example = true;
         description = "Autostart an IHaskell notebook service.";
       };
 
       haskellPackages = mkOption {
-        type = lib.types.packageSet;
         default = pkgs.haskellPackages;
         defaultText = "pkgs.haskellPackages";
         example = literalExample "pkgs.haskell.packages.ghc784";
@@ -35,9 +33,7 @@ in
       };
 
       extraPackages = mkOption {
-        type = types.functionTo (types.listOf types.package);
         default = self: [];
-        defaultText = "self: []";
         example = literalExample ''
           haskellPackages: [
             haskellPackages.wreq