about summary refs log tree commit diff
path: root/nixos/modules/services/misc/cpuminer-cryptonight.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/misc/cpuminer-cryptonight.nix')
-rw-r--r--nixos/modules/services/misc/cpuminer-cryptonight.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/services/misc/cpuminer-cryptonight.nix b/nixos/modules/services/misc/cpuminer-cryptonight.nix
index f31526f8d107..907b9d90da29 100644
--- a/nixos/modules/services/misc/cpuminer-cryptonight.nix
+++ b/nixos/modules/services/misc/cpuminer-cryptonight.nix
@@ -28,15 +28,15 @@ in
         '';
       };
       url = mkOption {
-        type = types.string;
+        type = types.str;
         description = "URL of mining server";
       };
       user = mkOption {
-        type = types.string;
+        type = types.str;
         description = "Username for mining server";
       };
       pass = mkOption {
-        type = types.string;
+        type = types.str;
         default = "x";
         description = "Password for mining server";
       };
@@ -63,4 +63,4 @@ in
 
   };
 
-}
\ No newline at end of file
+}