summary refs log tree commit diff
path: root/nixos/modules/services/hardware/thinkfan.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/hardware/thinkfan.nix')
-rw-r--r--nixos/modules/services/hardware/thinkfan.nix24
1 files changed, 17 insertions, 7 deletions
diff --git a/nixos/modules/services/hardware/thinkfan.nix b/nixos/modules/services/hardware/thinkfan.nix
index 16c31aab2d50..018e82e58a3d 100644
--- a/nixos/modules/services/hardware/thinkfan.nix
+++ b/nixos/modules/services/hardware/thinkfan.nix
@@ -43,13 +43,7 @@ let
 
     sensor ${cfg.sensor} (0, 10, 15, 2, 10, 5, 0, 3, 0, 3)
     
-    (0,     0,      55)
-    (1,     48,     60)
-    (2,     50,     61)
-    (3,     52,     63)
-    (6,     56,     65)
-    (7,     60,     85)
-    (127,   80,     32767)
+    ${cfg.levels}
   '';
 
 in {
@@ -72,6 +66,22 @@ in {
         '';
       };
 
+      levels = mkOption {
+        default = ''
+          (0,     0,      55)
+          (1,     48,     60)
+          (2,     50,     61)
+          (3,     52,     63)
+          (6,     56,     65)
+          (7,     60,     85)
+          (127,   80,     32767)
+        '';
+        description =''
+          Sensor used by thinkfan
+        '';
+      };
+
+
     };
 
   };