about summary refs log tree commit diff
path: root/nixos/modules/services/audio/wyoming/openwakeword.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/services/audio/wyoming/openwakeword.nix')
-rw-r--r--nixos/modules/services/audio/wyoming/openwakeword.nix22
1 files changed, 10 insertions, 12 deletions
diff --git a/nixos/modules/services/audio/wyoming/openwakeword.nix b/nixos/modules/services/audio/wyoming/openwakeword.nix
index 06b7dd585fda..713945c1df62 100644
--- a/nixos/modules/services/audio/wyoming/openwakeword.nix
+++ b/nixos/modules/services/audio/wyoming/openwakeword.nix
@@ -22,15 +22,6 @@ let
     toString
     ;
 
-  models = [
-    # wyoming_openwakeword/models/*.tflite
-    "alexa"
-    "hey_jarvis"
-    "hey_mycroft"
-    "hey_rhasspy"
-    "ok_nabu"
-  ];
-
 in
 
 {
@@ -51,15 +42,22 @@ in
     };
 
     models = mkOption {
-      type = listOf (enum models);
-      default = models;
+      type = listOf str;
+      default = [
+        # wyoming_openwakeword/models/*.tflite
+        "alexa"
+        "hey_jarvis"
+        "hey_mycroft"
+        "hey_rhasspy"
+        "ok_nabu"
+      ];
       description = mdDoc ''
         List of wake word models that should be made available.
       '';
     };
 
     preloadModels = mkOption {
-      type = listOf (enum models);
+      type = listOf str;
       default = [
         "ok_nabu"
       ];