summary refs log tree commit diff
path: root/nixos/modules/security/prey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/security/prey.nix')
-rw-r--r--nixos/modules/security/prey.nix21
1 files changed, 15 insertions, 6 deletions
diff --git a/nixos/modules/security/prey.nix b/nixos/modules/security/prey.nix
index e29fa5395a1a..1c643f2e1a57 100644
--- a/nixos/modules/security/prey.nix
+++ b/nixos/modules/security/prey.nix
@@ -16,19 +16,28 @@ in {
         default = false;
         type = types.bool;
         description = ''
-          Enables http://preyproject.com/ bash client. Be sure to specify api and device keys.
-          Once setup, cronjob will run evert 15 minutes and report status.
+          Enables the <link xlink:href="http://preyproject.com/" />
+          shell client. Be sure to specify both API and device keys.
+          Once enabled, a <command>cron</command> job will run every 15
+          minutes to report status information.
         '';
       };
 
       deviceKey = mkOption {
-        type = types.string;
-        description = "Device Key obtained from https://panel.preyproject.com/devices (and clicking on the device)";
+        type = types.str;
+        description = ''
+          <literal>Device key</literal> obtained by visiting
+          <link xlink:href="https://panel.preyproject.com/devices" />
+          and clicking on your device.
+        '';
       };
 
       apiKey = mkOption {
-        type = types.string;
-        description = "API key obtained from https://panel.preyproject.com/profile";
+        type = types.str;
+        description = ''
+          <literal>API key</literal> obtained from
+          <link xlink:href="https://panel.preyproject.com/profile" />.
+        '';
       };
     };