summary refs log tree commit diff
path: root/nixos/modules/programs/zsh/oh-my-zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/programs/zsh/oh-my-zsh.nix')
-rw-r--r--nixos/modules/programs/zsh/oh-my-zsh.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/modules/programs/zsh/oh-my-zsh.nix b/nixos/modules/programs/zsh/oh-my-zsh.nix
index 446c05da39d0..aa5844cdc4d4 100644
--- a/nixos/modules/programs/zsh/oh-my-zsh.nix
+++ b/nixos/modules/programs/zsh/oh-my-zsh.nix
@@ -42,6 +42,10 @@ in
     };
 
     config = mkIf cfg.enable {
+
+      # Prevent zsh from overwriting oh-my-zsh's prompt
+      programs.zsh.promptInit = mkDefault "";
+
       environment.systemPackages = with pkgs; [ oh-my-zsh ];
 
       programs.zsh.interactiveShellInit = with pkgs; with builtins; ''