summary refs log tree commit diff
path: root/nixos/modules/programs/nylas-mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/programs/nylas-mail.nix')
-rw-r--r--nixos/modules/programs/nylas-mail.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/nixos/modules/programs/nylas-mail.nix b/nixos/modules/programs/nylas-mail.nix
index d1427d890245..fc18a9a4760b 100644
--- a/nixos/modules/programs/nylas-mail.nix
+++ b/nixos/modules/programs/nylas-mail.nix
@@ -19,16 +19,6 @@ in {
         default = true;
         description = "Enable gnome3 keyring for nylas-mail.";
       };
-
-      package = mkOption {
-        type = types.package;
-        default = pkgs.nylas-mail;
-        defaultText = "pkgs.nylas-mail";
-        example = literalExample "pkgs.nylas-mail";
-        description = ''
-          nylas-mail package to use.
-        '';
-      };
     };
   };
 
@@ -37,7 +27,11 @@ in {
 
   config = mkIf cfg.enable {
 
+    environment.systemPackages = [pkgs.nylas-mail];
 
+    services.gnome3.gnome-keyring = mkIf cfg.gnome3-keyring {
+      enable = true;
+    };
 
   };
 }