summary refs log tree commit diff
path: root/nixos/modules/profiles/graphical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/profiles/graphical.nix')
-rw-r--r--nixos/modules/profiles/graphical.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/nixos/modules/profiles/graphical.nix b/nixos/modules/profiles/graphical.nix
new file mode 100644
index 000000000000..75ac5e41f83e
--- /dev/null
+++ b/nixos/modules/profiles/graphical.nix
@@ -0,0 +1,14 @@
+# This module defines a NixOS configuration that contains X11 and
+# KDE 4.  It's used by the graphical installation CD.
+
+{ config, pkgs, ... }:
+
+{
+  services.xserver = {
+    enable = true;
+    displayManager.kdm.enable = true;
+    desktopManager.kde4.enable = true;
+  };
+
+  environment.systemPackages = [ pkgs.glxinfo ];
+}