summary refs log tree commit diff
path: root/nixos/modules/profiles/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/profiles/base.nix')
-rw-r--r--nixos/modules/profiles/base.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/profiles/base.nix b/nixos/modules/profiles/base.nix
index 20b808c29e08..562419b3facb 100644
--- a/nixos/modules/profiles/base.nix
+++ b/nixos/modules/profiles/base.nix
@@ -34,6 +34,7 @@
     pkgs.dosfstools
     pkgs.xfsprogs
     pkgs.jfsutils
+    pkgs.f2fs-tools
     #pkgs.jfsrec # disabled because of Boost dependency
 
     # Some compression/archiver tools.
@@ -50,6 +51,6 @@
   ];
 
   # Include support for various filesystems.
-  boot.supportedFilesystems = [ "btrfs" "reiserfs" "vfat" ];
+  boot.supportedFilesystems = [ "btrfs" "reiserfs" "vfat" "f2fs" ];
 
 }