summary refs log tree commit diff
path: root/nixos/modules/misc/label.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/misc/label.nix')
-rw-r--r--nixos/modules/misc/label.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/misc/label.nix b/nixos/modules/misc/label.nix
index 30d8fc9952b7..5faac8936f8f 100644
--- a/nixos/modules/misc/label.nix
+++ b/nixos/modules/misc/label.nix
@@ -3,14 +3,14 @@
 with lib;
 
 let
-  cfg = config.system;
+  cfg = config.system.nixos;
 in
 
 {
 
   options.system = {
 
-    nixosLabel = mkOption {
+    nixos.label = mkOption {
       type = types.str;
       description = ''
         NixOS version name to be used in the names of generated
@@ -26,7 +26,7 @@ in
   config = {
     # This is set here rather than up there so that changing it would
     # not rebuild the manual
-    system.nixosLabel = mkDefault cfg.nixosVersion;
+    system.nixos.label = mkDefault cfg.version;
   };
 
 }