summary refs log tree commit diff
path: root/nixos/modules/misc/crashdump.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/misc/crashdump.nix')
-rw-r--r--nixos/modules/misc/crashdump.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/misc/crashdump.nix b/nixos/modules/misc/crashdump.nix
index 6e6bc9dec0f3..6e71baa9a431 100644
--- a/nixos/modules/misc/crashdump.nix
+++ b/nixos/modules/misc/crashdump.nix
@@ -14,8 +14,8 @@ in
     boot = {
       crashDump = {
         enable = mkOption {
+          type = types.bool;
           default = false;
-          example = true;
           description = ''
             If enabled, NixOS will set up a kernel that will
             boot on crash, and leave the user to a stage1 debug1devices
@@ -35,6 +35,7 @@ in
           '';
         };
         kernelParams = mkOption {
+          type = types.listOf types.str;
           default = [ "debug1devices" ];
           description = ''
             Parameters that will be passed to the kernel kexec-ed on crash.