summary refs log tree commit diff
path: root/nixos/modules/misc/check-config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/misc/check-config.nix')
-rw-r--r--nixos/modules/misc/check-config.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/modules/misc/check-config.nix b/nixos/modules/misc/check-config.nix
new file mode 100644
index 000000000000..f759c88d3a1f
--- /dev/null
+++ b/nixos/modules/misc/check-config.nix
@@ -0,0 +1,15 @@
+{ pkgs, ... }:
+
+with pkgs.lib;
+
+{
+  options = {
+    environment.checkConfigurationOptions = mkOption {
+      type = types.bool;
+      default = true;
+      description = ''
+        Whether to check the validity of the entire configuration.
+      '';
+    };
+  };
+}