summary refs log tree commit diff
path: root/nixos/modules/misc/assertions.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/misc/assertions.nix')
-rw-r--r--nixos/modules/misc/assertions.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/misc/assertions.nix b/nixos/modules/misc/assertions.nix
index 229f8f278608..5fb88308b776 100644
--- a/nixos/modules/misc/assertions.nix
+++ b/nixos/modules/misc/assertions.nix
@@ -15,10 +15,10 @@ in
   options = {
 
     assertions = mkOption {
+      type = types.listOf types.unspecified;
       internal = true;
       default = [];
       example = [ { assertion = false; message = "you can't enable this for that reason"; } ];
-      merge = pkgs.lib.mergeListOption;
       description = ''
         This option allows modules to express conditions that must
         hold for the evaluation of the system configuration to