summary refs log tree commit diff
path: root/nixos/modules/misc/assertions.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/misc/assertions.nix')
-rw-r--r--nixos/modules/misc/assertions.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/misc/assertions.nix b/nixos/modules/misc/assertions.nix
index c1be36e98cba..c42de038e61f 100644
--- a/nixos/modules/misc/assertions.nix
+++ b/nixos/modules/misc/assertions.nix
@@ -21,7 +21,7 @@ with lib;
     warnings = mkOption {
       internal = true;
       default = [];
-      type = types.listOf types.string;
+      type = types.listOf types.str;
       example = [ "The `foo' service is deprecated and will go away soon!" ];
       description = ''
         This option allows modules to show warnings to users during