summary refs log tree commit diff
path: root/nixos/modules/installer/cd-dvd/installation-cd-base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/installer/cd-dvd/installation-cd-base.nix')
-rw-r--r--nixos/modules/installer/cd-dvd/installation-cd-base.nix15
1 files changed, 1 insertions, 14 deletions
diff --git a/nixos/modules/installer/cd-dvd/installation-cd-base.nix b/nixos/modules/installer/cd-dvd/installation-cd-base.nix
index 5bd10823108c..bc3bd872d2a5 100644
--- a/nixos/modules/installer/cd-dvd/installation-cd-base.nix
+++ b/nixos/modules/installer/cd-dvd/installation-cd-base.nix
@@ -7,8 +7,7 @@ with lib;
 
 {
   imports =
-    [ ./channel.nix
-      ./iso-image.nix
+    [ ./iso-image.nix
 
       # Profiles of this basic installation CD.
       ../../profiles/all-hardware.nix
@@ -21,18 +20,6 @@ with lib;
 
   isoImage.volumeID = substring 0 11 "NIXOS_ISO";
 
-  # Make the installer more likely to succeed in low memory
-  # environments.  The kernel's overcommit heustistics bite us
-  # fairly often, preventing processes such as nix-worker or
-  # download-using-manifests.pl from forking even if there is
-  # plenty of free memory.
-  boot.kernel.sysctl."vm.overcommit_memory" = "1";
-
-  # To speed up installation a little bit, include the complete stdenv
-  # in the Nix store on the CD.  Archive::Cpio is needed for the
-  # initrd builder.  nixos-artwork is needed for the GRUB background.
-  isoImage.storeContents = [ pkgs.stdenv pkgs.busybox pkgs.perlPackages.ArchiveCpio pkgs.nixos-artwork ];
-
   # EFI booting
   isoImage.makeEfiBootable = true;