summary refs log tree commit diff
path: root/nixos/modules/hardware/pcmcia.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/hardware/pcmcia.nix')
-rw-r--r--nixos/modules/hardware/pcmcia.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/hardware/pcmcia.nix b/nixos/modules/hardware/pcmcia.nix
index 0dba59734ca7..dea04ac753c6 100644
--- a/nixos/modules/hardware/pcmcia.nix
+++ b/nixos/modules/hardware/pcmcia.nix
@@ -18,16 +18,16 @@ in
 
     hardware.pcmcia = {
       enable = mkOption {
+        type = types.bool;
         default = false;
-        merge = mergeEnableOption;
         description = ''
           Enable this option to support PCMCIA card.
         '';
       };
 
       firmware = mkOption {
+        type = types.listOf types.path;
         default = [];
-        merge = mergeListOption;
         description = ''
           List of firmware used to handle specific PCMCIA card.
         '';