summary refs log tree commit diff
path: root/nixos/modules/config/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/config/networking.nix')
-rw-r--r--nixos/modules/config/networking.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/config/networking.nix b/nixos/modules/config/networking.nix
index 760f8353fb30..6035facb594e 100644
--- a/nixos/modules/config/networking.nix
+++ b/nixos/modules/config/networking.nix
@@ -212,13 +212,13 @@ in
         # /etc/hosts: Hostname-to-IP mappings.
         "hosts".text =
           let oneToString = set : ip : ip + " " + concatStringsSep " " ( getAttr ip set );
-              allToString = set : concatStringsSep "\n" ( map ( oneToString set ) ( builtins.attrNames set ));
+              allToString = set : concatMapStringsSep "\n" ( oneToString set ) ( attrNames set );
               userLocalHosts = optionalString
                 ( builtins.hasAttr "127.0.0.1" cfg.hosts )
-                ( concatStringsSep " " ( filter (x : x != "localhost" ) ( getAttr "127.0.0.1" cfg.hosts)));
+                ( concatStringsSep " " ( remove "localhost" cfg.hosts."127.0.0.1" ));
               userLocalHosts6 = optionalString
                 ( builtins.hasAttr "::1" cfg.hosts )
-                ( concatStringsSep " " ( filter (x : x != "localhost" ) ( getAttr "::1" cfg.hosts)));
+                ( concatStringsSep " " ( remove "localhost" cfg.hosts."::1" ));
               otherHosts = allToString ( removeAttrs cfg.hosts [ "127.0.0.1" "::1" ]);
               maybeFQDN = optionalString ( cfg.fqdn != null ) cfg.fqdn;
           in