summary refs log tree commit diff
path: root/nixos/modules/config/ldap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/config/ldap.nix')
-rw-r--r--nixos/modules/config/ldap.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/modules/config/ldap.nix b/nixos/modules/config/ldap.nix
index 7064ef64b4c8..7cbcc39412ea 100644
--- a/nixos/modules/config/ldap.nix
+++ b/nixos/modules/config/ldap.nix
@@ -62,6 +62,12 @@ in
         description = "Whether to enable authentication against an LDAP server.";
       };
 
+      loginPam = mkOption {
+        type = types.bool;
+        default = true;
+        description = "Whether to include authentication against LDAP in login PAM";
+      };
+
       server = mkOption {
         example = "ldap://ldap.example.org/";
         description = "The URL of the LDAP server.";