summary refs log tree commit diff
path: root/nixos/lib/testing/jquery-ui.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/lib/testing/jquery-ui.nix')
-rw-r--r--nixos/lib/testing/jquery-ui.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/nixos/lib/testing/jquery-ui.nix b/nixos/lib/testing/jquery-ui.nix
new file mode 100644
index 000000000000..e65107a3c2fb
--- /dev/null
+++ b/nixos/lib/testing/jquery-ui.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchurl, unzip }:
+
+stdenv.mkDerivation rec {
+  name = "jquery-ui-1.11.4";
+
+  src = fetchurl {
+    url = "http://jqueryui.com/resources/download/${name}.zip";
+    sha256 = "0ciyaj1acg08g8hpzqx6whayq206fvf4whksz2pjgxlv207lqgjh";
+  };
+
+  buildInputs = [ unzip ];
+
+  installPhase =
+    ''
+      mkdir -p "$out/js"
+      cp -rv . "$out/js"
+    '';
+
+  meta = {
+    homepage = http://jqueryui.com/;
+    description = "A library of JavaScript widgets and effects";
+    platforms = stdenv.lib.platforms.all;
+  };
+}