summary refs log tree commit diff
path: root/modules/system/upstart-events/shutdown.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/upstart-events/shutdown.nix')
-rw-r--r--modules/system/upstart-events/shutdown.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/system/upstart-events/shutdown.nix b/modules/system/upstart-events/shutdown.nix
index 78d848df6639..8aa794378ed3 100644
--- a/modules/system/upstart-events/shutdown.nix
+++ b/modules/system/upstart-events/shutdown.nix
@@ -136,7 +136,7 @@ with pkgs.lib;
               echo Enter 'i' to launch a shell, or wait 10 seconds to continue.
               read -t 10 A
               if [ "$A" == "i" ]; then
-                bash -i < /dev/console &> /dev/console
+                ${pkgs.bashInteractive}/bin/bash -i < /dev/console &> /dev/console
               fi
               sleep 5
           fi